Wins blog

글로벌 정보보안 파트너! Global Security  No.1 윈스는 국가대표 정보보안 기업에서 글로벌 강소기업으로 도약합니다.

보안 정보

앞 내용 보기 다음 내용 보기
취약점 정보[CVE-2020-11108] Pi-hole gravity.sh RCE
작성일 2020-11-20 조회 20

 

 

PiHole 4.40 이하 버전에 원격 코드 실행 취약점이 존재합니다.

 

Pi-hole은 Linux 네트워크 수준의 광고 및 인터넷 추적기 차단 응용 프로그램으로, 사설 네트워크에서 사용하기 위한 DNS 싱크홀 및 DHCP 서버 역할을 합니다.

 

 


해당 취약점은 gravity.sh 내 gravity_DownloadBlocklistFromUrl의 코드 결함으로 인해 발생합니다.

 

 


원격의 공격자가 악의적으로 조작된 요청을 전송하여 공격을 성공시킬 수 있습니다.

 

 

 

 

 

취약점 설명

 

NVD - CVE-2020-11108

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM

 

 

 

[그림1. NVD 내역]

 

 

 

 

취약점 분석

 

해당 취약점은 gravity.sh 내 gravity_DownloadBlocklistFromUrl의 코드 결함으로 인해 발생합니다. 

 

 

 

PoC 코드를 살펴보면,

/settings.php?tab=blocklists로 보내는 요청의 

newuserlists 매개변수에 희생자의 IP를 넣어 백도어를 생성하는 것을 확인할 수 있습니다.

 

 

 

[그림2. CVE-2020-11108 PoC]

 

 

 

 

 

공격 분석

 

 

공개된 PoC를 기반으로 CVE-2020-11108에 대한 공격 패킷은 다음과 같습니다.


POST 요청을 통해 newuserlists 파라미터의 값으로 희생자 IP주소를 입력하는 것을 확인할 수 있습니다.

 

 

 

[그림3. CVE-2020-11108 공격 패킷]

 

 

 

패치된 버전에서는 차단 목록, 블랙리스트 및 화이트리스트는 모두 개별적으로 활성화 / 비활성화 할 수 있게 설정함으로써 해당 취약점을 방지하는 것을 확인할 수 있습니다.

 

 

 

[그림 4. CVE-2020-11108 패치 내역]

 

 

 

취약점 대응 방안

 

 

1. 최신 버전 사용

 

해당 벤더사에서 발표한 보안 권고문을 참고하여 패치를 적용합니다.

https://github.com/pi-hole/AdminLTE

 

 

2. WINS Sniper 제품군 대응 방안

 

Pi-hole gravity.sh RCE

첨부파일 첨부파일이 없습니다.
태그 Pi-hole  CVE-2020-11108